Bug sur la gestion des radars tronçons

Fichiers .TXT
Répondre
ctve
Membre
Membre
Messages : 6
Enregistré le : 25 janvier 2019, 11:38
Vehicule(s) : Mazda CX-3 2.0 Skyactiv-G 150 4X4
GPS : Mazda MZD Connect

Bug sur la gestion des radars tronçons

Message par ctve » 13 mars 2019, 11:20

Bonjour à tous,

J'utilise depuis peu Igo Primo depuis le GPS MZD de ma Mazda en utilisant le fichier speedcam.txt téléchargé bien sûr sur Lufop et je rencontre un curieux bug.

Si les radars fixes "normaux" et les radars de feux sont bien annoncés et bien gérés, il n'en est pas de même avec les radars tronçons (ou radars de vitesse moyenne selon l'appellation igo).

En effet, au début du tronçon l'icône et l'annonce correspondante s'affichent bien ; par contre, à la fin du tronçon, au lieu d'annoncer la fin du tronçon et d'effacer l'icône, celle-ci reste présente et j'ai à nouveau l'annonce d'un nouveau radar tronçon.

Pensant à un mauvais codage du radar concerné dans le fichier speedcam, j'ai fait l'essai avec un autre radar tronçon et c'est pareil.

Quelqu'un a-t-il constaté le même phénomène et comment peut-on le résoudre ?

Merci d'avance pour vos réponses.

ctve
Membre
Membre
Messages : 6
Enregistré le : 25 janvier 2019, 11:38
Vehicule(s) : Mazda CX-3 2.0 Skyactiv-G 150 4X4
GPS : Mazda MZD Connect

Re: Bug sur la gestion des radars tronçons

Message par ctve » 23 mars 2019, 11:14

Bonjour,

Cela fait 10 jours que j'ai posté ce sujet qui a été vu plus de 100 fois et ... pas une seule réponse ou réaction de qui que ce soit.

Suis-je seul à rencontrer ce problème ?

hb31
Membre
Membre
Messages : 4
Enregistré le : 09 avril 2016, 18:38
Vehicule(s) : Opel - Camping-car Rapido
GPS : Gps autonome tournant sous iGo - Gps Pioneer (CC) base iGo

Re: Bug sur la gestion des radars tronçons

Message par hb31 » 03 avril 2019, 16:06

Bonjour,

J’ai personnellement un multimédia Pioneer dont le GPS est basé sur iGo 8, ainsi qu’un GPS iGo 8.

J’ai pu constaté le problème suivant pour les radars de tronçon, qui est malheureusement inévitable.
Rien n’indique au GPS que c’est un début de tronçon ou une fin.
Sur une route dégagée en principe çà fonctionne très bien, début de tronçon, puis plus loin fin du tronçon, à condition que le point GPS de la fin soit bien en bordure de la route et non pas à 30 m dans le champ à coté.
Mais souvent les radars de tronçon sont utilisés dans les tunnels, vous voyez bien l’entrée du tunnel, donc début d’un tronçon, mais le tunnel est assez long et en virage, donc perte du signal GPS, vous allez bien arriver au bout du tunnel, le GPS va reprendre sa position aussitôt que le ciel sera dégagé, malheureusement vous avez dépassé la position de la fin de tronçon, donc le tronçon continue, pour peu que vous soyez sur une autoroute avec plusieurs tunnels à tronçon, comme c’est le cas en Espagne, l’entrée dans le tunnel suivant sera pour votre GPS la fin du premier tronçon, et vous serais complètement décalé.

ctve
Membre
Membre
Messages : 6
Enregistré le : 25 janvier 2019, 11:38
Vehicule(s) : Mazda CX-3 2.0 Skyactiv-G 150 4X4
GPS : Mazda MZD Connect

Re: Bug sur la gestion des radars tronçons

Message par ctve » 07 avril 2019, 15:43

Bonjour et merci pour ta réponse.

Hélas, elle ne résout pas mon problème.
En effet, j'ai trois radars tronçons près de chez moi. Tous sont en zone parfaitement dégagée et sur autoroute ou voie rapide de surcroît. Il n'y a donc pas de perte de signal GPS comme cela pourrait être le cas dans un tunnel que tu évoques en exemple.
Pourtant, pour les trois, Igo considère que la fin d'une zone est en fait le début d'une nouvelle zone tronçon.

hb31
Membre
Membre
Messages : 4
Enregistré le : 09 avril 2016, 18:38
Vehicule(s) : Opel - Camping-car Rapido
GPS : Gps autonome tournant sous iGo - Gps Pioneer (CC) base iGo

Re: Bug sur la gestion des radars tronçons

Message par hb31 » 08 avril 2019, 13:28

Bonjour,

Un autre phénomène constaté avec iGo8, quand les points GPS ne sont pas tout à fait exacts, une fois sur une autoroute, début de section ok, puis la fin de section, pour le GPS, a eu lieu une centaine de mètre avant la fin réelle, puis bien sûr début d’une nouvelle section à la place de la fin de la première.
J’ai donc regardé les coordonnées sur Google Earth, le début et la fin de section, points GPS corrects sur la droite de la voie. Mais en sens inverse il y avait aussi un radar de section légèrement décalé en vérifiant le point GPS du début, au lieu d’être sur la droite de la voie inverse, il était entre les deux voies, ce qui a déclenché la fin de section pour mon GPS.
Depuis je vérifie tous les radars de section sur Google Earth et je les modifie au besoin, surtout à l’étranger où souvent on n’a pas le sens de la direction.

ctve
Membre
Membre
Messages : 6
Enregistré le : 25 janvier 2019, 11:38
Vehicule(s) : Mazda CX-3 2.0 Skyactiv-G 150 4X4
GPS : Mazda MZD Connect

Re: Bug sur la gestion des radars tronçons

Message par ctve » 09 avril 2019, 10:40

hb31 a écrit :
08 avril 2019, 13:28
... puis la fin de section, pour le GPS, a eu lieu une centaine de mètre avant la fin réelle, puis bien sûr début d’une nouvelle section à la place de la fin de la première.
Ton explication est parfaitement logique et je l'admets bien volontiers mais, le problème en ce qui me concerne, c'est que je n'ai JAMAIS vu s'afficher de fin de radar tronçon.

Comment sont-elles codées dans le fichier speedcam.txt ? En effet, le début d'une zone de radar tronçon est codé par 4 mais, dans la doc que j'ai, il n'y aucun code numérique d'indiqué pour la fin d'une zone de radar tronçon.

hb31
Membre
Membre
Messages : 4
Enregistré le : 09 avril 2016, 18:38
Vehicule(s) : Opel - Camping-car Rapido
GPS : Gps autonome tournant sous iGo - Gps Pioneer (CC) base iGo

Re: Bug sur la gestion des radars tronçons

Message par hb31 » 09 avril 2019, 11:50

Bonjour,

Il n'y a pas de différence entre début et fin tout est codé 4, ce qui permet le bon fonctionnement c'est la direction la fin doit être dans la même direction que le début, si çà ne fonctionne pas soit il n'y a pas de direction c'est le cas souvent des radars étrangers, dans ce cas le moindre radar de section dans l'autre sens va déclencher la fin, (c'est le cas que j'évoquais plus haut), soit la direction n'est pas tout à fait dans le sens de la route dans la fin de section, et le radar de fin est ignoré. Ce que j'en dit c'est concernant IGo8, maintenant il y a peut-être un bug dans primo ?
Pour les radars de section qui ne fonctionnent pas il faudrait regarder avec Google Earth si les directions du début et de la fin sont bien dans le sens de la route !

Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Bing [Bot] et 0 invité